Dark Clan Forum

Welcome, Guest. Please login or register.

Login with username, password and session length
Pages: [1]   Go Down
Print
Author Topic: Demospeed & dumpframe issues  (Read 1063 times)
SavagE
Newbie
*
Offline Offline

Posts: 9


« on: Sun 16.02.2014 06:12:04 »

First off I'm new to UT3 moviemaking scene, so I may not know issues that are known to ya'll. When I play a demo with rypelcam it starts at "1x" speed, but the actual speed is "hyper", around 5 times faster than it should be. It creates issues when I want to dumpframe, since rypel doesnt allow me to dump with custom playback speed, it always reverts to 1x no matter what I do. Also when I try to modify UTRypelCam.ini to accommodate my preferable settings (120 fps), when I load up the game Rypel always reverts to default values. How do I make my demos play at regular speed? And why cant I dump at custom playback speed?

On a side note - I cant set texture quality in settings to 5/5. When I reload the game it always reverts to 3/5 :( And how can I remove/mute those special weapon hit sounds? For instance, when you frag someone with Flak something like a bottle-open sound plays.

Lastly - could you modify RypelCam to accommodate higher dumpframe settings (above 120) and enable simultaneous sound recording?

VegasKill
Administrator
*
Offline Offline

Posts: 3869



« Reply #1 on: Sun 16.02.2014 11:29:24 »

First off I'm new to UT3 moviemaking scene
Hi!

When I play a demo with rypelcam it starts at "1x" speed, but the actual speed is "hyper", around 5 times faster than it should be.
The game runs faster (or slower, depending on your PC performance and graphics settings) when you start it as 'benchmark'. 'Benchmrak' is important if you want to dump screenshots, since the Engine waits for all scripts and operations to complete before rendering a new frame. This means, it does not matter how powerful your PC is or how long it takes to save a screenshot to your hard disk drive, your screenshots will always generate a fluid movie with your configured FPS rate.

To run UT3 with 'benchmark', you can add -benchmark to the shortcut path of UT3.exe as a command line parameter (your shortcut probably already looks like this):

"C:\Program Files (x86)\Unreal Tournament 3\Binaries\UT3.exe" -Benchmark

https://udn.epicgames.com/Three/CommandLineArguments.html:
Code:
BENCHMARK: Run game at fixed-step in order to process each frame without skipping any frames.
This is useful in conjunction with DUMPMOVIE options.

FPS: set the frames per second for benchmarking.


Unfortunately, the -FPS command line parameter works in UDK but not in UT3. So the Engine plays the game as fast as possible at fixed 30 FPS of gameplay speed.



rypel doesnt allow me to dump with custom playback speed
RypelCam allows you to dump screenshots at your custom FPS rate by changing the demo playback speed in proportion to the dumpframes FPS you want to record at (playbackspeed = 30 / dumpframesFPS).
But you have to open the RypelCam menu in game (press R) and configure the Dumpframe FPS there, if you don't want to record at 30 FPS (Main Menu > Dumpframes > record screenshots at FPS).

If you set 120 FPS and start dumping screenshots, you should see the demo playback speed in the HUD dropping to 0.25 (30FPS/120FPS).



Also when I try to modify UTRypelCam.ini to accommodate my preferable settings (120 fps), when I load up the game Rypel always reverts to default values.
Good point, will be changed in a future RypelCam to load the settings from UTRypelCam.ini.


How do I make my demos play at regular speed?
You can start UT3 without -benchmark to run demos at the regular speed. To run UT3 without -benchmark, create a shortcut to UT3.exe, and leave it as is (or at least, do not add the -benchmark command line parameter :-) ):

"C:\Program Files (x86)\Unreal Tournament 3\Binaries\UT3.exe"

Just make sure you use -benchmark when you want to record screenshots, or your movie won't have a constant FPS rate.




On a side note - I cant set texture quality in settings to 5/5. When I reload the game it always reverts to 3/5 Sad
You have to be logged in to your profile for UT3 to save graphics settings. If you choose to play offline, changes made to this guest profile are volatile.
But this can be useful as well, if you don't want to have your profile settings modified. For example, if you find bloom and depth of field disturbing while playing, but you want to make a video with RypelCam with all the eye candies active. When you leave the guest account by logging in to your profile, the settings for bloom, depth of field and so on are discarded, you don't have to go in the graphics menu and disable them manually.

A helpful advice: To load the maximum graphics settings, you can as well use the RypelCam menu (press R): Main Menu > Graphics > Set High Quality Graphics.
If you are logged in to your profile, changes are permanent, otherwise the graphics reset when you restart the game or log in to your profile.




And how can I remove/mute those special weapon hit sounds? For instance, when you frag someone with Flak something like a bottle-open sound plays.
Hitsounds are not a RypelCam or UT3 feature. Sounds like they are added by mutators like UTComp, ATB or similar. If these mutators were active while the demo was recorded, they will be loaded for the demo playback as well. The UTComp menu can be opened with F5, and, I think, you can change some of the UTComp settings also during demo playback.



Lastly - could you modify RypelCam to accommodate higher dumpframe settings (above 120)
In theory, yes. In fact, when a future RypelCam loads the dumpframes settings from UTRypelCam.ini, you will be able to set any value you want in the .ini.
But since the FPS commandline parameter does not work in UT3, the gameplay speed is locked at 30FPS. In order to record, for example, at 300FPS, RypelCam would reduce the demo playback speed to 0.1 (30FPS/300FPS). Such low playback speed causes new problems. You can test it yourself, go below 0.1 playback speed during the demo playback (without even dumping screenshots), there will be lots of jitter in the player movements. The Unreal Engine 3 does a very, very bad job in interpolating the player movements in demos. It is unlikely that RypelCam can fix that.



and enable simultaneous sound recording?
No, unachievable with just unrealscript in RypelCam. Even in UDK, where Epic allows you to record directly to avi video, sound is not recorded.
https://udn.epicgames.com/Three/CapturingCinematicsAndGameplay.html#Capturing%20Sound

Mess with the best, die like the rest
SavagE
Newbie
*
Offline Offline

Posts: 9


« Reply #2 on: Sun 16.02.2014 23:34:30 »

Thanks for a warm welcome and this elaborate reply, Rypel! You've been very helpful, I think I have sorted out POV recording, so the basics are covered. Recording 120 FPS has a normal speed in the end, so I got what I wanted.

The F5 menu actually lets you manipulate those sounds and a couple of other features! Also RypelCam menu indeed forced the game to set highest detail values.

I think I just have one question for now - can I turn on just the crosshair like in UT99?
SavagE
Newbie
*
Offline Offline

Posts: 9


« Reply #3 on: Mon 17.02.2014 00:22:47 »

Oh and why "avoidphysicsbug" makes weapon in FPP mode invisible? (another post; didnt see edit option)
VegasKill
Administrator
*
Offline Offline

Posts: 3869



« Reply #4 on: Mon 17.02.2014 13:19:20 »

I'm in the RypelCam developer team, but I'm not RypeL. Wink


Sometimes, in UT3 client demos, the physics of a player pawn change to 'falling' and are not restored to 'walking'.
You can tell you have this bug if a player moves like this:
http://youtu.be/Mwndtja_IUk

"avoidphysicsbug" overwrites the physics to be rigid, keeping the first person view of that player somewhat functional, but the weapon and the arms are no longer turned correctly in front of the player, so they have to be hidden. The effect lasts until the player dies and should only be applied if you encounter this error, and the error repeats every time you play the demo.




I don't know what you mean with crosshair in UT99, maybe someone else can help out here?
There is an option in the UT3 menu to change between the regular crosshair and a simple version. Also, UTComp has crosshair options and allows you to create custom crosshairs.

Mess with the best, die like the rest
SavagE
Newbie
*
Offline Offline

Posts: 9


« Reply #5 on: Mon 17.02.2014 14:37:28 »

I was just asking if you could somewhat keep the crosshair on when you turn off the hud in RC. Also what does the option "First person movie mode" do?
VegasKill
Administrator
*
Offline Offline

Posts: 3869



« Reply #6 on: Mon 17.02.2014 19:33:31 »

I was just asking if you could somewhat keep the crosshair on when you turn off the hud in RC.
Also what does the option "First person movie mode" do?
You gave yourself the answer. "First person movie mode" allows to remove some hud elements without hiding the entire hud. The crosshair, messages for kills/sprees/weapon pickups and more stay visible, whereas the minimap, weapon bar etc. are removed. In case the hud is hidden, you can make it visible with 'h'.

Mess with the best, die like the rest
Pages: [1]   Go Up
Print
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
© 2008-2016 | design by radarfox | webmaster VegasKill